No reading from scale

8 posts / 0 new
Last post
Lars
No reading from scale

Hi, new user here and need some help.

I have set up this for a friend and done a test run in the Livingroom without scale and it's ok.
Now when we are testing with scale we are not getting any numbers.
On the Rasperry there is som weird info.

Pictures of the info and scale setup.

Image: 
First info
Second info
Scale 1
Scale 2
Paul
Paul's picture
PI not talking to HX711

The Pi is not talking to the HX711. i is undefined (a "feature") because i is never set since there are no readings from the HX711 (Yes, that needs to be fixed to a more informative error message.) Each time the scale is read, the HX711 is read 64 times, the median calculated, outliers thrown away and the rest averaged.You should get the same error message with the HX711 board unplugged.

Don't worry about the load cell side right now, Check the side with the 4 pins on the HX711. Check the soldering on the HX711 board, the hive interface board where the HX711 plugs in, and contacts pins 16 and 18 on the 40 pin connector on the hive interface board.

With everything plugged in but not powered, check resistance between the 4 contacts on the HX711 board and +5, ground, H2 pins 16 and 18. Also, with the power on, you should measure 5 VDC on the power supply pins on the HX711 (I think they are the two outside pins on the 4 pin connector.

Again, don't worry about the load cell side yet. You need to talk to the HX711 before you worry about that. There is no circuitry on the hive interface board between the Pi and the HX711, only connectors, solder and PCB traces

Very interesting frame design, by the way. Any particular design goals or improvements with this design?

Lars
Thanks for the quick reply

I will do some measuring and check the solderings.

The frame is Bernt's design. Just tried to get a stable construction with the material he hade.
We hopes it will work.

Lars
So, now I have done some

So, now I have done some resoldering and measuring, but no luck.
I still have same weird info as before.
What's next to do?

Paul
Paul's picture
What version image and try hx711 command

Couple of questions, Lars.

Which image are you running.

What happens when you run

sudo hx711

from the command line?

You should get about 64 lines of numbers.

Thanks!

Lars
I haven't change anything on

I haven't change anything on the memory card I got in the delivery. I think it's 0.7.4

Will see what the sudo command will say.

Paul
Paul's picture
Also try the other HX711 driver

Lars, Also try the other HX711 driver.

From the configuration page, in the drop down, there is HX711py and HX711. Please try the HX711 driver (it is c code, HX711py is python code.) I think the python driver works a little better but right now we are just trying to figure out if it is hardware or software. 0.7.4 should be fine.

Lars
It was easy as that.

It was easy as that.
I have change the setting from HX711py to HX711 and now its working.

Thank you.

Log in to post comments