New TEMPerHum code

2 posts / 0 new
Last post
Nate
Nate's picture
New TEMPerHum code

I didn't stumble upon the post suggesting the TEMPerHum sticks may not be the way to go as the code seems to be a moving target so I went ahead and purchased a couple

After purchasing a couple of these modules, however I did get a lot of help from Adam getting it to work. I ended up with a version 1.3 it's got a silver metallic housing that looks exactly like the older ones

Here's the procedure adam worked out for me to get the modules reading

Update files are located here… how to install them on the device Adam helped me out with the following directions
https://github.com/mushisushi/TEMPered/
sudo git clone git://github.com/mushisushi/TEMPered
cd TEMPered
sudo ccmake . #(note the period on the end – this should open ccmake and show ‘empty cache’)
# Press [c] to configure. Errors may pop up, ignore them by pressing [e].
# Press [c] to configure again. [e] again.
# Press [g] to generate the cmake files.
sudo make install
If compile is successful, you can test it out by:
cd utils
sudo ./tempered
Should read all your devices.
IF THAT WORKS – you will copy the tempered binary file into /usr/local/bin so that the command can be run globally.
sudo cp ./tempered /usr/local/bin/.
Typing sudo tempered from anywhere should work then.

Some helpful info for doing manual updated (from Adam)
Remember that files and directories (although everything is a ‘file’ in *nix) are case-sensitive. In this case the directories are TEMPered
So you would ‘cd TEMPered’
When using the terminal, the following shortcuts are useful:
Cd .. (two dots) = go up the directory tree
Cd - (hyphen) = go to last visited directory
When using the terminal, a single period ‘.’ Is the shortcut that refers to the current working directory.
It looks like you are trying to use:

Make sure to use SUDO when running the ccmake command too. It needs those root privileges.
PS – LS is the *nix equivalent of dir in DOS

Image: 
Esa
Esa's picture
new batch of TEMPerHum not working

Hi,

trying to build up new Hivetool with 0.7.3rc2 HiveControl 1.81 with newly purchased TEMPerHums I got following
error "/dev/hidraw3: Could not open device: Unknown device subtype string: TEMPer1F_H1V1.5F"

the instructions above worked fine with older versions of TEMPerHums, but not with these new ones.

#lsusb
Bus 001 Device 007: ID 0c45:7402 Microdia TEMPerHUM Temperature & Humidity Sensor

#usb-devices -h
T: Bus=01 Lev=02 Prnt=02 Port=04 Cnt=05 Dev#= 7 Spd=1.5 MxCh= 0
D: Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS= 8 #Cfgs= 1
P: Vendor=0c45 ProdID=7402 Rev=00.01
S: Manufacturer=RDing
S: Product=TEMPer1F_H1_V1.4
C: #Ifs= 2 Cfg#= 1 Atr=a0 MxPwr=100mA
I: If#= 0 Alt= 0 #EPs= 1 Cls=03(HID ) Sub=01 Prot=01 Driver=usbhid
I: If#= 1 Alt= 0 #EPs= 1 Cls=03(HID ) Sub=01 Prot=02 Driver=usbhid

Any ideas how to get this to work ?

Log in to post comments