Last readings not showing on local website

4 posts / 0 new
Last post
Last readings not showing on local website

The last readings are not showing on my local website (192.168.1.x). It shows on Can someone tell me what I need to change in the file to fix this?

Paul's picture
Bug Fix

Delete or comment out line 904 in

if ( @row = $sth->fetchrow() ) {

@row = $sth->fetchrow(); <============== DELETE ME!

$last_end_time = $row[0];

Esa's picture
what is the difference

what is the difference between the hive_stats3w... and hive_stats4w...? any documentation about all these scripts ...

Do I have something wrong with my Pi setup, wrong sw version as the local webpage uses ?

Paul's picture
4 is just a later version of

4 is just a later version of 3 where I tried to fix problems in 3 but didn't like it. 3 seems better than 4 so now I am setting the default version to 3 until I get a chance to work on another version. If a data set won't graph, try changing the url from 3 to 4 or 4 to 3 (you can do this on, too. I think if the weight data starts with no reading or a bad reading, the weight filter won't not work. I tried to fix that in 4 but introduced other graphing problems with the rain. The code is a mess and either needs to be completely rewritten or start fresh with a different graphing package.

Log in to post comments